Cyprus Eastern Forum Archive


This is a text archive version of our main content. To view the full site with more information, features, formatting and images please click here.

>> Eastern Cyprus Forum Archive Index

View The Full Original Topic: Ford Audio 2000 Radio Problem


>> Have YOUR say - Post A Reply To This Topic

Posted By: Stabilo

I should add that the base, treble & balance etc on the radio works i.e. the small hiss moves from left to right and front to rear speakers as you move the balance control knob. Any car radio shops open on Saturday afternoon in Paralimni?



Posted By: Stabilo

Spent several hours removing a cassette that was stuck in the unit. Downloaded the software for the unlock code only to find the code was handwritten on the unit when I removed it. Blew a fuse and replaced it. Now the radio comes on for FM, LW & MW but no sound. With sound at the maximum there is a small hiss from the speakers but no radio stations. Any ideas?

Posted By: carts320

aerial not connected correctly?

Posted By: Stabilo

  • carts320 wrote:
    aerial not connected correctly?

Could be.
Just finished reading the Haynes manual and off to check the aerial amplifier connection in the rear parcel shelf.

Posted By: carts320

  • Stabilo wrote:
    • carts320 wrote:
      aerial not connected correctly?

    Could be.
    Just finished reading the Haynes manual and off to check the aerial amplifier connection in the rear parcel shelf.

If it was working before you had the head unit out then 99% sure it's the aerial plug....

Posted By: Stabilo

  • carts320 wrote:
    • Stabilo wrote:
      • carts320 wrote:
        aerial not connected correctly?

      Could be.
      Just finished reading the Haynes manual and off to check the aerial amplifier connection in the rear parcel shelf.

    If it was working before you had the head unit out then 99% sure it's the aerial plug....

I have never had the radio working as the previous owner got the tape stuck several years ago. Aerial connection on the head unit looks fine and the aerial amplifier connections are SOLID. Tried a random piece of coax in the back of the head unit just in case the aerial amplifier has blown and still no radio stations.
I read elsewhere that just because the display comes on the radio and certain functions work it doesn't mean the radio works (blown capacitor etc), is this likely?
Tried swapping with another unit but I need to pick up a Ford to standard radio plug adapter before I can do this as my other unit isn't a Ford radio.

Posted By: alanandmaria

I have a Ford 2000 in warehouse. I dont bother trying to sell now as everyone wants CD's. If you pay postage from UK you can have it for free. I might even have a 4000 or 5000 in a car at yard. one of them would be 10 plus post 2kg size 20 x 20 x 15 cm's Or if you know someone coming over I could post to them On your set you trying to repair if you use the station search does it just continuously search and never find a station? I have had quite a few over the years do that. They just hiss constantly even if you manually tune to station

Posted By: Stabilo

  • alanandmaria wrote:
    I have a Ford 2000 in warehouse. I dont bother trying to sell now as everyone wants CD's. If you pay postage from UK you can have it for free. I might even have a 4000 or 5000 in a car at yard. one of them would be 10 plus post
    2kg size 20 x 20 x 15 cm's
    Or if you know someone coming over I could post to them
    On your set you trying to repair if you use the station search does it just continuously search and never find a station? I have had quite a few over the years do that. They just hiss constantly even if you manually tune to station

Yes it just searches continuously and when I set a station like Napa (106.3) nothing. It only hisses very quietly and that is with volume at maximum.
Might take you up on the 2000.





Posted By: alanandmaria

Then I think you will find fit for bin. I have seen people advertise repairs for them but on a 2000 not worth it. I had quick look at post and about 27 Would love to find cheaper alternative but posting to Cyprus is a joke. Royal mail are about 40 But you welcome to this one for cost of post Alan

Posted By: Stabilo

Alan, You don't happen to have a Blue Ford cable from head unit to graphic equaliser do you or know where we might get one? It would be to go with your 2008 unit. The one we have was only wired up at the head unit and it is a nightmare trying to manually wire up the other end.

Posted By: alanandmaria

Hi, I have two Fords in yard at moment. A 2004 Fiesta & a 2002 Focus & don't think either will have the cable you are after. What year and model are you fitting this stereo to? Alan

Posted By: Stabilo

A 1990 Ford Granada Mk3 Scorpio. Think I might be ok without the cable if you don't have one.


[ ADVERTS: UK Stores Delivering To Cyprus | Find eBay Misspellings - Grab A Bargain! ]



Viewing Cyprus Eastern Forum Archive - Lo-Fi Version | Visit Cyprus Eastern Forum - Full Version | Questions?

TOP TIP: BUYING PROPERTY IN CYPRUS? PLEASE ENSURE THAT YOU SEEK INDEPENDANT LEGAL ADVICE FIRST.
Cyprus forum covering Kapparis, Protaras, Pernera, Agia Napa, Agia Thekla, Paralimni, Larnaca, Oroklini, Pervolia & surrounding areas
Please note that the views expressed on this forum are those of the author and may not reflect the views of the management.